Thursday, May 8, 2008

AoC Closed Beta Patched = FAITH RESTORED

I'll admit, despite my obvious love for the game, I was worried that the launch for Funcom's Age of Conan was not going to be a pretty thing based on the Open Beta client fiasco. But today (or yesterday and today really), they patched the client up to what has got to be the most smooth version I've seen since I began in February.

There are still some kinks, as in some people are finding checkerboard textures due to their video-cards while others aren't, and NPCs are stuck in some funny positions, but these are "KNOWN ISSUES (tm)" and Funcom says they're already fixed in an internal build.

What I was met with today upon logging in was drastically reduced loading times, no more popping-in textures, and in general about a 15FPS improvement over the previous version. Also what they've always referred to as client stalling (stuttering) is gone for me, the BLOOM effect doesn't cut my FPS at all, and even fatalities seem more in sync animation wise. It's just... more fine-tuned and much more the type of client one would expect to see this close to release.

I don't know about miracles and patches being mentioned together... but this thing comes close. Let's just hope they don't drop they ball they've picked up and this is the client players in the Open Beta see on the 10th.

5 comments:

Openedge1 said...

I am totally basing my faith on this game on how it plays, and you Closed Beta testers...

I hope this is on the Up, and Up...as I really love the game and 90% of the time the game is smooth...
Then sometimes I hit a snag, a load issue or texture pops, stalls, etc...
But, I totally blame this OB.
I found some tricks (delete cache files, rename intro bik files to cut loads in half..) and they work
Now...if I can play with zero trickery (like I really, REALLY want that bloom on...), then I will be there for the long haul.

Thanks for the information

Ardwulf said...

Good to know that my preorder money just might not have been entirely wasted.

Good show!

Andrew said...

Good to hear, I was getting worried with all reports of bugs on the forums.

Keen said...

Glad it worked for you Bildo. Within 15 minutes of playing I could spot a dozen or so things it broke though. :(

I guess the best thing to come from this is the load times being shorter. Being stuck in 2.0 shaders, character animations being botched, and having flickering white and black checker boxes sucks though

slashrandom said...

It fixed a ton of things for me as well. I'll be posting a little later, and checking Keen's blog to see what broke. I didn't notice too much breaking, I mostly noticed fixing.